Exige S1 190 ECU

Discussion on the K-series engine that powers our car.
LTG
Posts: 5
Joined: Tue Jun 02, 2009 6:19 pm

Exige S1 190 ECU

Post by LTG » Mon Sep 24, 2012 7:23 pm

Hello,

how can I recognize an Exige S1 190 ECU from the standard 179PS one without using the Lotus scan tool?

Wasn't it that the standard one rev only to 7800rpm and the 190 to 8000?

PS: The 102� pulley is not installed and nothing is written on the ECU.

User avatar
tim_marra
Posts: 4748
Joined: Tue Jan 13, 2004 4:56 pm
Location: Cumbria

Re: Exige S1 190 ECU

Post by tim_marra » Mon Sep 24, 2012 9:12 pm

The 190 ECU usually has '190' written on it in crayon or similar*











*I kid you not :)

User avatar
Esprit
Posts: 949
Joined: Sat May 26, 2007 1:11 pm
Location: Auckland, New Zealand

Re: Exige S1 190 ECU

Post by Esprit » Wed Sep 26, 2012 2:53 am

Mine has "190 Upgrade" written on it in blue marker pen. That's the only thing most of them have.

User avatar
pete757
Posts: 3519
Joined: Wed Sep 27, 2006 1:50 pm
Location: Perth OZ

Re: Exige S1 190 ECU

Post by pete757 » Wed Sep 26, 2012 12:04 pm

My question of a few weeks ago too!!! :D

I obtained a 190 ecu from a guy of SELOC/MLOC Who's car had been converted to a 190 by Nick Whale and the factory and invoiced as such. There was NOTHING written on the ECU!!! But I am certain it is a 190 as the engine now goes to 8000 with much better power than my OEM 177!!!

DAVE Andrews fitted it and also checked the cam timing... I was planning to get him to fit and time Verniers, but the weird thing was the 'standard' pullies were spot on timed for the 190 advanced inlet cam!! WIERD EH!!!

So! It seems that not all 190 ECU,s have 190 written on them!!!

Good luck!!! :crazy:

User avatar
jfk
Posts: 3252
Joined: Wed Jul 30, 2008 9:50 pm
Location: Dudlaay.

Re: Exige S1 190 ECU

Post by jfk » Fri Sep 28, 2012 10:48 am

WH Smith do a blue marker pen for 99p ...
It's a very nice marker pen !
;)

LTG
Posts: 5
Joined: Tue Jun 02, 2009 6:19 pm

Re: Exige S1 190 ECU

Post by LTG » Mon Oct 01, 2012 9:00 am

WH Smith do a blue marker pen for 99p ...
lol :D

Thanks anyway for your inputs.

User avatar
Esprit
Posts: 949
Joined: Sat May 26, 2007 1:11 pm
Location: Auckland, New Zealand

Re: Exige S1 190 ECU

Post by Esprit » Mon Oct 01, 2012 11:09 pm

Image

That's mine, when it was in the car.

Slightly more expensive now!

Image

User avatar
pete757
Posts: 3519
Joined: Wed Sep 27, 2006 1:50 pm
Location: Perth OZ

Re: Exige S1 190 ECU

Post by pete757 » Tue Oct 02, 2012 10:00 am

Cool George!

Lighter too!!! :cool:

User avatar
Esprit
Posts: 949
Joined: Sat May 26, 2007 1:11 pm
Location: Auckland, New Zealand

Re: Exige S1 190 ECU

Post by Esprit » Tue Oct 02, 2012 10:48 am

Excuse the bracket for the MoTeC... that was one I made up to hold a Link G4 computer before I changed to the M800... the proper bracket that's in the car now is a lot tidier :)

User avatar
pete757
Posts: 3519
Joined: Wed Sep 27, 2006 1:50 pm
Location: Perth OZ

Re: Exige S1 190 ECU

Post by pete757 » Wed Oct 03, 2012 1:44 am

Excused!!!

Blimey George!!! You are a total perfectionist!!! I presume all of this is still hidden out of sight behind the Plastic bulkhead!!! ;)

Post Reply